Security Advisory: Chrome and Edge Browser Vulnerability


SERVICE(S) AFFECTED:          
Google Chrome and Microsoft Edge Web Browsers

TIME OF OCCURRENCE:        
Wednesday November 18, 2020 (11:30 am) AT

AFFECTED USERS:                  
All Users of Windows, Mac, and Linux Operating Systems

ACTION:
Please ensure that your system is running the most up-to-date version of the Google Chrome and Microsoft Edge web browsers.  There were several security patches recently released for Chrome.

To verify and install the most recent browser version, go to the upper right hand corner and select the 3 dots:

  1. Windows: From within the browser, go to Help > About Google Chrome or Help & Feedback > About Microsoft Edge.
  2. Mac: From within the browser, click on the top menu bar title for Chrome > About Google Chrome or Help & Feedback > About Microsoft Edge.

Please ensure that you receive the message that your browser is up-to-date.  It may take several upgrades.

For further information on updating Web Browsers see: https://hub.acadiau.ca/TDClient/KB/ArticleDet?ID=762

MORE INFO:
Google Chrome has announced a high severity vulnerability, affecting Chrome and Microsoft Edge web browsing for all major operating systems including Windows, Mac, and Linux. An updated version of the web browsers have been released.

CONTACT:
Acadia Technology Services
http://ts.acadiau.ca
hub.acadiau.ca
Live Chat
902-585-4357 | 1-888-609-3330
Twitter | Facebook

SUPPORT:
All maintenance and Service Advisories are posted in several locations:  Twitter or Facebook or the TS website.  All scheduled work is placed on the Maintenance Calendar.  
Follow our Tuesday Tech Tips - https://hub.acadiau.ca/TDClient/KB/?CategoryID=124
For an overview on Technology Services Support Protocols, please see: https://hub.acadiau.ca/TDClient/KB/ArticleDet?ID=924


Go back